‹ back home

Running Eve-Online on Linux/Wayland

2021-12-07

Initially, the launcher would render only a black window, and nothing else. I noticed that moving it off-screen and back again, it would have updated content, but remained frozen.

As a coincidence, I noticed that when moved onto the edge of the screen, parts near the edge would render, and would respond to input events, whereas other parts didn’t.

This made it obvious that the game was doing something funny with window positioning. I’ve a dual screen setup, with one screen on the top-right of the other, so neither of them are at the 0x0 coordinates. The launcher assumes the current monitor is in the upper-left position, and won’t render or react to events otherwise. I’ve no idea if this is a wine issue, an xwayland issue, or an eve-launcher issue, but changing the position of my monitor fixed it.

After that, I had to copy over the file as mentioned in other posts on ProtonDB. I’m using Flatpak, so the base path varies a little:

cd .var/app/com.valvesoftware.Steam/  # this line only applicable if using Flatpak
cd .local/share/Steam/steamapps/common/Eve\ Online/SharedCache/
cp tq/bin64/eve_client_launchdarkly_client.pyd tq/
chmod 400 tq/eve_client_launchdarkly_client.pyd

Trying to switch the game window itself from fullscreen to non-fullscreen resulted in all mouse events having an offset of a few pixels. I tried switching the game to Windowed mode via the game menu, but initially had the same issue. However, fullscreening that window and un-fullscreenining it back fixed it.

It seems the game won’t correctly handle being fullscreen externally (e.g.: by a global hotkey); it’s best if you limit yourself to only doing this via the in-game menu.

— § —